Signups Down
Incident Report for Endless Hosting
Resolved
This incident has been resolved.
Posted 16 days ago. May 31, 2019 - 23:14 UTC
Investigating
Signups are not going through to JIRA
Posted 16 days ago. May 31, 2019 - 08:41 UTC
This incident affected: EH Systems (Homepage/Signups).