Billing and internal Jira/Confluence instances partially unavailable
Incident Report for Endless Group
Resolved
This incident has been resolved.
Posted Feb 08, 2020 - 19:56 EST
Investigating
We are currently investigating issues that affect our Billing Portal (portal.theendlessweb.com) and our Jira/Confluence instances.

We'll let you know once we have an update.
Posted Feb 08, 2020 - 12:41 EST
This incident affected: EH Systems (Helpdesk, Billing).